Back to overview
Downtime

Full server outage

May 17, 2024 at 6:52am UTC
Affected services
bcnlab.org

Resolved
Jun 4, 2024 at 1:15pm UTC

Everything back to normal

Updated
May 27, 2024 at 4:52pm UTC

We have restored a few of our services.

Updated
May 21, 2024 at 8:49am UTC

The issue is still present. Our hosting provider is still trying to solve the issue.

Created
May 17, 2024 at 6:52am UTC

Our servers are currently inaccesible due to a problem with our server hosing provider. We hope to be back online in a few hours.